Ducati Scrambler Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 2015 ICOIN and bike is Jerking dangerously while engaging the clutch.
Problem started just before warranty was due! Took the bike to dealer where I bought the bike from In Vancouver Canada
( High road Vancouver ) "mechanic" did some adjustments and blamed the problem on my riding skill ! and basically they totally ignored the issue which sometimes can be very dangerous especially if you carry a passenger ,Bike has only 7000K on it now and problem is still there.
Anyone had or has same clutch problem, and can you please share ?
 

·
Registered
Joined
·
3 Posts
That doesn't seem right. Mine is a 2015 ICON. It doesn't have this problem. Sometimes I have difficulty switching in higher gears. I learned that's mostly rider error.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
That doesn't seem right. Mine is a 2015 ICON. It doesn't have this problem. Sometimes I have difficulty switching in higher gears. I learned that's mostly rider error.
thanks for the reply , I found another icon owner who has same problem. it almost appear every one has some sort of premature clutch wear or stickiness issue with Scrambler, I hope that dont happen to you,
Here it is .:
I have an issue with the clutch since I got the bike.
When the bike is cold and when I pull the clutch in for the first time it makes a small clicking sound and feels like something is released. After that first pull, next ones feel fine.

Then when its time to move and I start releasing the clutch for the first time, the bike jerks forward a bit while still in the friction zone. Feels like the plates grip suddenly. It also makes a weird grrrch sound at the same time.

This usually happens 'only once' when starting the ride. It's perfectly fine after that. Actually it is so fine that i never even had any trouble finding neutral once. I can find neutral first try every try and it's all very smooth. Never even had one false neutral between any gear. Considered myself pretty lucky reading other riders problems with false neutrals.

The bike is now at 700 km's, i thought this issue would go away after the first few hundred km's of breaking in but it's still here so I though I could share it with you. If you have any experiences like this with your scrambler or your other bikes, I appreciate all the info. Thanks.


SaveShare
Reply



D
Doc59
Registered

Joined Feb 13, 2015
134 Posts
#2 May 13, 2015
 
1 - 3 of 3 Posts
Top