Gages flash, click & no start - Ducati Scrambler Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 12-17-2019, 03:36 PM Thread Starter
Junior Member
 
T-Rock's Avatar
 
Join Date: Sep 2016
Location: Buckeye, AZ
Posts: 20
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Garage
(Thread Starter)
Gages flash, click & no start

Can’t determine if my battery is a problem or something else. The gauges just flash each time I press the starter button and a single click type sound happens. It doesn’t sound like it is trying to turn over. Not sure if I should just replace the battery or if there’s other troubleshooting I can do. Any ideas are appreciated.

------- T-Rock -------
2016 Scrambler Icon
North County San Diego
T-Rock is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-21-2019, 10:12 PM
Junior Member
 
Join Date: Feb 2018
Location: Northville, MI
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
I would say the battery is bad. Would rule that out first off before anything else. Take the battery to an auto parts store and see if they can put it on a battery analyzer. Sounds like what happens when the battery goes bad in my cars.
Mikemagic is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome