Front LED turns and turn-cancel not working - Ducati Scrambler Forum
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 09-27-2016, 11:10 AM Thread Starter
Junior Member
 
Graham's Avatar
 
Join Date: Sep 2015
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Front LED turns and turn-cancel not working

So my friend had a little incident and broke off the turn signals and cracked the gauge. New gauge installed by my local Ducati dealer, and new Ducati LED turn signals installed. They say no need for a new relay or resistors, etc. Just a plug and play upgrade. However...

- The front turn signals don't work, and the rear signals blink fast.
- Also, the turn-cancel button does not work. I tried switching out the left side switch, same issue. I checked all the connections, all of them snap together securely.

I checked the wiring diagram in the back of the manual and the gauge seems to control turn signal function and turn cancellation too. Any thoughts before I just turn it over to Ducati and hand over my credit card? Thanks in advance.

2016 Scrambler - urban enduro -
Graham is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-27-2016, 11:20 AM
Junior Member
 
GTRider's Avatar
 
Join Date: Nov 2015
Location: EVANSVILLE, IN
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Just a thought...With conventional incandescent bulbs, it doesn't matter which direction the electrical current flows, so they can be connected with either polarity. But that's not the case with LEDs. Is it possible they are connected with the wrong polarity? It might be as simple as removing the front bulbs, rotating them 180 degrees, and reinstalling them.

Good luck,
Chris
GTRider is offline  
post #3 of 7 (permalink) Old 09-27-2016, 12:22 PM Thread Starter
Junior Member
 
Graham's Avatar
 
Join Date: Sep 2015
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Thanks Chris! Well I replace all four with "official" Ducati LED units, from the dealer. The connectors are all factory matched so I'm fairly confident I didn't switch anything around??

2016 Scrambler - urban enduro -
Graham is offline  
 
post #4 of 7 (permalink) Old 09-29-2016, 11:36 AM Thread Starter
Junior Member
 
Graham's Avatar
 
Join Date: Sep 2015
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Does anyone know if the new gauge activation(which only Ducati can do), which includes needing all the keys to match immobilizer signature.. could have some affect on the turn signal functionality? In other words, is it possible they could have "messed up" activating the new gauge(which plays a part in the turn signal circuitry)?

2016 Scrambler - urban enduro -
Graham is offline  
post #5 of 7 (permalink) Old 09-30-2016, 04:55 AM
Senior Member
 
Derek's Avatar
 
Join Date: Dec 2014
Location: Scotland
Posts: 250
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 80 Post(s)
Quote:
Originally Posted by Graham View Post
Thanks Chris! Well I replace all four with "official" Ducati LED units, from the dealer. The connectors are all factory matched so I'm fairly confident I didn't switch anything around??
I heard recently of a Panigale owner here in the UK fitting factory supplied LED indicators and finding that the wires in the connector had their polarity reversed.
I'd be going back to the dealer who supplied and fitted the new dash. They obviously didn't check that all functions were operating correctly after fitting it.

2015 Scrambler Classic
2010 MTS1200
1994 907ie
1982 Pantah 500SL
Derek is offline  
post #6 of 7 (permalink) Old 10-01-2016, 03:29 PM Thread Starter
Junior Member
 
Graham's Avatar
 
Join Date: Sep 2015
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Quote:
Originally Posted by Derek View Post
I heard recently of a Panigale owner here in the UK fitting factory supplied LED indicators and finding that the wires in the connector had their polarity reversed.
I'd be going back to the dealer who supplied and fitted the new dash. They obviously didn't check that all functions were operating correctly after fitting it.
Interesting Derek, I'll check wiring at the connector. I'm almost at the point where I'm going to have the dealer take another look.

2016 Scrambler - urban enduro -
Graham is offline  
post #7 of 7 (permalink) Old 10-20-2016, 11:45 AM Thread Starter
Junior Member
 
Graham's Avatar
 
Join Date: Sep 2015
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Update: (In case anyone cares, haha)

Got nowhere switching wires around. So I called Ducati and dropped the bike off. They tried to reprogram the gauge and had connectivity issues at the gauge connector. It seems they did not catch this connector issue when I dropped the bike off for their "crash analysis" so we could get a better idea of the extent of damage and costs, etc. They now want to replace the entire bike harness(because the plug does not come separately).. parts and labor around $1200. Ugh....

2016 Scrambler - urban enduro -
Graham is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome